System is down for some international markets

Incident Report for Property Meld

Resolved

This incident has been resolved.
Posted Jun 06, 2025 - 16:38 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2025 - 13:48 EDT

Identified

We have investigated this issue and narrowed the scope of this outage to the Philippines. It appears to be an problem limited to certain ISPs within the country, CONVERGE etc.
Posted Jun 06, 2025 - 09:50 EDT

Update

We have escalated the issue to AWS support and opened a case top address the region specific timeout.
Posted Jun 05, 2025 - 15:45 EDT

Investigating

We are experiencing a complete system outage across international markets. We have identified the cause as an issue with our CDN, Cloudfront, delivering static assets to said international markets. Our apologies for any inconvenience.
Posted Jun 05, 2025 - 12:53 EDT
This incident affected: System.